Latência ao gravar guitarra com amplitube

    Autor Mensagem
    Gui_guita
    Membro Novato
    # 14/jan/22 06:42


    Bom dia galera, procurei bastante e não encontrei nenhum tópico que me sanasse essa questão tal e qual se apresenta pra mim.

    Tenho uma interface de áudio UM2 da Behringer, uso o drive original dela (Behringer USB audio) e a DAW é o Reaper. Na configuração da interface, deixei em Fast, que é o máximo que consigo diminuir no buffer size. Se eu colocar acima disso, para de reproduzir o áudio e começa a dar um click periódico, acredito que seja porque a interface não dá conta de um buffer acima.
    Meu notebook tem 8GB de RAM, processador Intel Core i5 M480 @ 2.67GHz.

    Fiz um teste de feedback (fiz um jumper entre a saída de fone da interface e a entrada de linha. Peguei um sinal com uma forma de onda fácil de visualizar um pico, para poder comparar a latência e puz para gravar. Sem ter nenhum plugin ligado, a diferença foi de 7 samples, ficando o áudio da monitoração - que foi gravado por estar feito o jumper - adiantado em relação ao sinal, mas essa diferença é praticamente insignificante ao gravar. Mas basta ligar o Amplitube que a latência passa a ser de 87 samples, sendo que agora o áudio da monitoração passa a ficar atrasado em relação ao sinal, o que torna impossível para gravar, pois a gravação fica bem fora do compasso).

    Aí toda vez que monto um timbre novo, tenho que ir, dentro da aba options - preferences - recording e setar um offset corrigindo a quantidade de samples de diferença que existe, só que cada vez que eu adiciono um novo plugin, ou adiciono mais algum efeito no próprio amplitube, tenho que refazer todo esse teste para evitar o atraso novamente e isso é bem desgastante e desanima pra caramba de gravar a guitarra, chego a perder o tesão por saber que vou ter toda essa mão toda hora pra gravar...

    Alguém poderia me dar uma mão de como eliminar essa latência e gravar de boa com plugin? Preciso trocar de interface? Meu computador é fraco para este fim? O que será uqe posso fazer?

    _JCM_
    Veterano
    # 14/jan/22 14:25
    · votar


    Gui_guita

    Boa tarde! ja baixou o driver asio4ALL?

    makumbator
    Moderador
    # 14/jan/22 14:54 · Editado por: makumbator
    · votar


    Cara, se a DAW está bem configurada ela mesmo calcuka os atrasos e ajusta tudo. Não precisa ficar mudando a cada plugin inserido. Cada plugin informa á DAW a quantidade de latência e ela calcula tudo e arruma para nada ser gravado fora de sync. Está estranho seu setup.

    Você selecionou o protocolo asio no reaper? Talvez tenha escolhido algum outro que é mais demorado.

    Informe em quanto está o buffer do reaper (e não em samples, mas em milissegundos). Na configuração de áudio há essa info. Vá mudando de acordo com seus testes. Cada computador é particular e pode ser preciso aumentar ou diminuir de acordo com o caso.

    Teste também com o amplitude em modo standalone (ou seja, sem ser como plugin dentro de uma daw).

    Gui_guita
    Membro Novato
    # 15/jan/22 07:49
    · votar


    Boa tarde! ja baixou o driver asio4ALL?

    Já baixei sim e testei com ele também, porém piorou ainda mais...

    Gui_guita
    Membro Novato
    # 15/jan/22 08:01
    · votar


    Você selecionou o protocolo asio no reaper? Talvez tenha escolhido algum outro que é mais demorado.

    Selecionei sim.

    Informe em quanto está o buffer do reaper (e não em samples, mas em milissegundos). Na configuração de áudio há essa info.

    Só me confirma se o diretório para acessar essa aba é esse por favor: Options -> Preferences -> Audio -> Buffering

    Seria aí? Se não for favor me informar o correto e citar bem certo a especificação que preciso te passar de buffer, pois nessa aba achei 3 informações referentes a buffer:
    Media buffer size: 120ms
    Prebuffer: 100%
    Media buffer size whe per-take FX UI open: 200ms

    Já na parte: Options -> Preferences -> Audio -> Device -> Asio Configuration

    Que é onde ele abre o drive da placa de áudio para configurar, em System performance eu deixei em "Fast" (Output latency 18ms Input latency 3ms) que é o máximo que consigo sem dar aquele clip que falei e mutar de vez o áudio.

    Sei que tá meio cheio de informaçoes mano, mas é uma pena que não consigo enviar print aqui, espero que entenda para poder me ajudar. Desde já eu agradeço também por já ter dado um norte inicial

    Schelb
    Veterano
    # 15/jan/22 11:26
    · votar


    Rapaz .. tem algo errado nessa configuração ou na instalação dos drivers. Uma coisa que me ocorre é que o driver asio4all tem uma janelinha de configuração que você tem que selecionar qual dispositivo está usando .. será que tem algo errado por ali? Se não for, acho que você desinstala o driver da behringer e instala de novo, porque ele não está funcionando da forma correta. Era pra você estar com uns 20ms de latência só .. o que é bem de boa. Eu tenho uma UM2 e gravo muito com 256 samples e vai muito bem .. num tem que preocupar com atraso nenhum. No meu caso já usei esse driver da behringer mas acabei voltando pro asio4all por que a configuração fora de daw é melhor pra mim .. mas todos os dois drivers vão muito bem pra gravação. As configurações do seu pc tbm eram pra aguentar de boa.

    makumbator
    Moderador
    # 15/jan/22 14:59
    · votar


    Gui_guita

    Eu não uso o Reaper, então não posso te falar exatamente ao de fica nele, mas deve ser nas configurações do programa.

    Ningen
    Veterano
    # 15/jan/22 17:30
    · votar


    Só me confirma se o diretório para acessar essa aba é esse por favor: Options -> Preferences -> Audio -> Buffering

    Seria aí? Se não for favor me informar o correto e citar bem certo a especificação que preciso te passar de buffer, pois nessa aba achei 3 informações referentes a buffer:
    Media buffer size: 120ms
    Prebuffer: 100%
    Media buffer size whe per-take FX UI open: 200ms


    Isso aqui não tem nada a ver com a história.

    Ningen
    Veterano
    # 15/jan/22 17:38
    · votar


    As configurações relacionadas a latência ficam nessa página.

    Você pode clicar no botão ASIO Configuration... e alterar as configurações no programa de driver de sua interface... Ou você pode fazer como eu fiz e marcar Request sample rate e Request block size (isso vai sobrescrever as configurações de driver da interface, o Reaper vai "tomar de conta")..

    48000 - 256 como eu fiz (no print) deve solucionar seus problemas.

    procurei bastante e não encontrei nenhum tópico que me sanasse essa questão

    Tá precisando ler mais. ~Amarante

    Ningen
    Veterano
    # 15/jan/22 17:44
    · votar


    48000 - 256 dá isso aqui de latência... (Conta matemática: 256/48=5.33 milissegundos. O meu Reaper tá mostrando 6.8/7.5 provavelmente por estar contando com latência extra de entrada e saída, clock USB e etc.)

    Gui_guita
    Membro Novato
    # 17/jan/22 06:33
    · votar


    Galera, de tanto fuçar finalmente consegui. Obrigado a todos que contribuíram de alguma forma. Analisando a fundo percebi que realmente a minha latência estava bem baixa e não deveria incomodar. Então investiguei e vi que na configuração do drive da interface (em Asio configuration) a configuração estava retornando para "normal" ao invés de "fast" que é onde a latência fica praticamente nula. É difícil de explicar sem mostrar mas como não sei anexar imagem fica assim mesmo. Cheguei a me perguntar se eu não estava tocando ligeiramente fora também, então fiz alguns testes com o próprio metrônomo do reaper tocando uma nota por tempo e o atraso foi mínimo, quase imperceptível, então agora está tudo ok. A maior parte do problema era a configuração da interface que saia do que eu ttinha setado, e um pouquinho a forma de tocar também, tudo influencia hehe.

    Obrigado a todos que colaboraram, de coração. Abraço!!!

      Você não pode enviar mensagens, pois este tópico está fechado.
       

      Tópicos relacionados a Latência ao gravar guitarra com amplitube